Автор Тема: Не работает SSO  (Прочитано 578 раз)

0 Пользователей и 1 Гость просматривают эту тему.

B@Ur

  • Гость
Не работает SSO
« : Июль 29, 2015, 08:59:55 pm »
Здравствуйте! Уважаемые форумчане, я в админах недавно поэтому немного в заблуждении, просто не знаю что делать. Вообщем ситуация такая есть определенная организация в этой организации настроен VPN между всеми филиалами которые расположены в разных городах, во всех филиалах подняты КДшки все они подчиняются одному Серверу Контроллеру Домена, на данном сервере создана политика для SSO подключения всех пользователей АД к порталу (сайту) каторый расположен на сервере головного офиса и для всех филиалов были созданы кэшируюшие сервера данного портала на базе Центос. проблема такая: когда я ввожу в адресную строку имя данного портала он должен цепляться на него через мой локальный кэширующий сервер но этого не происходит выходит ошибка якобы портал не доступен хотя когда пингую портал по доменному имени он пингует мой локальный кэш сервер, а если напрямую по айпишнику рубиться то запрашивает логин и пароль, но когда их вводишь просит повторить заного и так несколько раз потом перекидывает по внешнему айпишнику на портал (по внешнему айпи он работает). Суть в том что, должна быть доменная авторизация пользователя в винду, затем когда в браузере открываешь портал он автоматом логинит тебе под твоей учеткой посредством SSO. Вот такая вот проблема, извините если не понятно, трудно учитывать последовательность в данной ситуации)) если кто кинет хоть маленькую подсказку в каком направлении двигаться?
в дополнение к теме, при попытке подключения к данному сайту выходит ошибка err_access_denied хотя пинг по этому адресу идет, если ввести напрямую айпи адрес то просит логин пароль (хотя должен заходить автоматом если зашел в винду под доменной учеткой) после ввожу логин и пароль но без результатно после повторения данной процедуры раза 3 он автоматом перекидывает на сайт по внешнему айпи адресу.

 

Оффлайн around

  • Сообщество ИТ-Специалистов
  • Специалист ИТ
  • ****
  • Сообщений: 380
  • Karma: +31/-0
  • Пол: Мужской
  • Ломаем Cisco, Huawei, QTech. Быстро, качественно!
    • Share Post
    • Сайт Кругликова
Re: Не работает SSO
« Ответ #1 : Июль 30, 2015, 03:19:50 pm »
Вот такая вот проблема, извините если не понятно, трудно учитывать последовательность в данной ситуации)) если кто кинет хоть маленькую подсказку в каком направлении двигаться?
Попытался понять, что у тебя там происходит... У тебя никаких Squid не установлено? Если установлено, то знает ли машина co Squid(oops, 3proxy), о DNS-имени твоего портала?
ping-то не через проксю идёт...
Опять же, err_access_denied говорит о том, что у тебя что-то с настройками ACL...
« Последнее редактирование: Июль 30, 2015, 03:21:38 pm от around »
roubles in Windows - reboot, troubles in *nix - be root.

B@Ur

  • Гость
Re: Не работает SSO
« Ответ #2 : Июль 30, 2015, 03:40:59 pm »
Привет! Нет сквида нет, у нас стоит cisco ASA firewall, и блочит все подряд кроме доверенных сайтов, а насчет ACL как проверить?

Оффлайн around

  • Сообщество ИТ-Специалистов
  • Специалист ИТ
  • ****
  • Сообщений: 380
  • Karma: +31/-0
  • Пол: Мужской
  • Ломаем Cisco, Huawei, QTech. Быстро, качественно!
    • Share Post
    • Сайт Кругликова
Re: Не работает SSO
« Ответ #3 : Июль 30, 2015, 04:25:48 pm »
Привет! Нет сквида нет, у нас стоит cisco ASA firewall, и блочит все подряд кроме доверенных сайтов, а насчет ACL как проверить?
Ну вот и смотрите в правилах асы, может что-то залочили... но тогда я не совсем понимаю, что подразумевается под


Цитировать
были созданы кэшируюшие сервера данного портала


B@Ur

  • Гость
Re: Не работает SSO
« Ответ #4 : Июль 30, 2015, 05:24:20 pm »
если честно не знаю, возможно что бы разгрузить центральный сервер

Оффлайн around

  • Сообщество ИТ-Специалистов
  • Специалист ИТ
  • ****
  • Сообщений: 380
  • Karma: +31/-0
  • Пол: Мужской
  • Ломаем Cisco, Huawei, QTech. Быстро, качественно!
    • Share Post
    • Сайт Кругликова
Re: Не работает SSO
« Ответ #5 : Июль 30, 2015, 05:50:48 pm »
если честно не знаю, возможно что бы разгрузить центральный сервер
ну если уж Вы не знаете, что они кешируют, то как мы можем знать, почему они не работают))))

B@Ur

  • Гость
Re: Не работает SSO
« Ответ #6 : Июль 30, 2015, 07:45:05 pm »
ну да)) ну скорее всего кэшируют они центральный сервер для его разгрузки, а вы как думаете для чего служат кэширующие серверы?

Оффлайн around

  • Сообщество ИТ-Специалистов
  • Специалист ИТ
  • ****
  • Сообщений: 380
  • Karma: +31/-0
  • Пол: Мужской
  • Ломаем Cisco, Huawei, QTech. Быстро, качественно!
    • Share Post
    • Сайт Кругликова
Re: Не работает SSO
« Ответ #7 : Июль 30, 2015, 07:51:49 pm »
ну да)) ну скорее всего кэшируют они центральный сервер для его разгрузки, а вы как думаете для чего служат кэширующие серверы?
Блин, может там bind кеширующий, может squid, может apache... откуда ж я знаю, что именно у Вас эти сервера кешируют... =)
В любом случае, я бы начал с ACL. Если нет доступа, значит где-то нет правила...

Оффлайн sysadmin

  • Administrator
  • сисадми́н
  • *****
  • Сообщений: 7934
  • Karma: +108/-0
  • Пол: Мужской
    • Share Post
    • сайт для сис. админов и не только...
Re: Не работает SSO
« Ответ #8 : Август 20, 2015, 12:20:04 pm »
В любом случае, я бы начал с ACL..
+

Автору темы - так же лезь в логи своих серверов, сетевых устройств, возможно там указана причина проблемы... И что за портал - SharePoint?
« Последнее редактирование: Август 20, 2015, 12:23:53 pm от sysadmin »
дорогу осилит идущий...
......................
MCP, MCTS, RHCSA
......................
also aka xck...


xx
На ноутбуке не работает HDMI, VGA работает нормально

Автор adil89

7 Ответов
848 Просмотров
Последний ответ Сентябрь 09, 2015, 04:39:01 pm
от Ćằɯeӈьҝẫ
xx
не работает cron

Автор bitmaster

15 Ответов
1674 Просмотров
Последний ответ Май 30, 2014, 02:25:32 pm
от bitmaster
xx
Не работает 301 редирект

Автор HorekRediskovich

16 Ответов
379 Просмотров
Последний ответ Июнь 15, 2016, 03:50:22 pm
от HorekRediskovich
exclamation
Не работает Nat в UserGate 2.8

Автор bessmertnyi_poni

3 Ответов
1822 Просмотров
Последний ответ Январь 17, 2014, 02:45:49 pm
от CyberPunk 2050