Sys-Admin Forum

Восстановление Raid 10

Всем доброго времени суток! Господа сегодня попросили помочь восстановить сервер, симптомы: тормозит. Сказали что был Raid настроен. Запустил, ввел стандартные команды и меня смутило разбиение и состояние рэйда. Понятно, что совсем пропал один из HDD, могу предположить что пропал sdc (так как видно что не хватает 3 hdd в рэйде) теперь под sdc работает sdd скорее всего.
Смутило состояние рэйда по нескольким причинам:

  1. md0 в состоянии inactive (в сервере всего 4 HDD и задействованы в md126), откуда взялся md0?
  2. md 126 (тоже странный зверь, раньше не встречал такого обозначения)
  3. Также смущает разбиение, на sda раздел md126 и далее подразделы md126p1 и т.д.
  4. Если смотреть таблицу разделов рабочего hdd, так там один раздел всего.

В общем просто я с таким разбиением не встречался и для получения ценнейшего опыта само собой я хочу починить этот сервер))).

Так как имею дело с чем то новым,у меня появились некоторые вопросы, когда начал составлять план действий.

  • После установки нового hdd. буду копировать таблицу разделов с любого из работающих HDD. Так вот, скопируется ли корректно разбиение md126.
    Команда стандартная: sfdisk -d /dev/sda | sfdisk /dev/sdd --force
    Тут уточню,что восстанавливал несколько серверов с raid1 и с raid10, но там было разбиение на sda: sda1, sda2, sda3. Командой выше или другой для gpt, просто копировал эти разделы на другой hdd и все, проблем не было. Далее добавлял новый hdd в массив и пошел процесс синхронизации.
    Тут же это разбиение меня сбивает с толку или разницы нет, разделы перенесуться как есть и все будет нормально. Может кто-то уже сталкивался с подобным, может есть камни подводные?

PS: просмотрел таблицу разделов на двух других hdd так там все ок (3 скрин).


raid.PNG

raid2.PNG